electronics, repairs, service manuals and datasheets discussion community for the repairs professionals and technicians
FAQSearchMembersGroupsRegisterProfilePM'sLogin/Out
CREATIVE MEGAWORKS 510D

 
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs
View previous topic :: View next topic  
Author Message
DANISH AHMAD
Guest





PostPosted: Fri Apr 07, 2006 8:55 pm    Post subject: CREATIVE MEGAWORKS 510D Reply with quote

I want creative megaworks 510d service manual or schematic, there is a problem in powersupply ( i thk probably in dc chopper) which is producing clipping sound in it during ON condition. can any one help me out how to fix this equipment.
Back to top
andreavassallo
Guest





PostPosted: Sun Sep 03, 2006 12:40 am    Post subject: yayks! Reply with quote

you have exactly my problem matey!
a problem with the power supply but no parts for it...
did u find a way of repairing it or at least get circuit manuals?
Back to top
nickbd
Guest





PostPosted: Wed Aug 29, 2007 3:00 am    Post subject: 510D clipping/power supply Reply with quote

I had the clipping for a long time and then eventually it would just shut off and occasionally work for a while. I took a look at the power supply outputs and on a scope some were definitely not smooth DC. Managed to blow something else while checking the voltages. So I managed to find a unit for sale that was working and when I have time I'll check the voltages which would be something to go from. I wonder if anyone else has done this or if there is info on this.
Back to top
bilbo76
Guest





PostPosted: Fri Mar 28, 2008 12:49 am    Post subject: Reply with quote

Hi guys. Any chance youve managed to find the service manual or found a way to fix it? This problem is annoying!

Thanks
Back to top
Guest






PostPosted: Fri Mar 28, 2008 4:17 pm    Post subject: Reply with quote

I have found if the sound has gone blippy then dissappeared, then I could cure it by leaving the sub on (including on at the remote), then just yank out the mains plug, leave for 10 seconds then plug it back in. Switch it on at the remote and hey presto, sound is back! (most of the time anyway).

Makes me think the capacitors isnt discharging properly or something.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs All times are GMT
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Електроника София - Service Manuals Free Download - Prikachi - Service Diagrams

Free TV Schematics Download - HARDW.net - Pinout Master - Jabse Search - Jabse.InK  - Pulsator

Connector Pinout Forum - Новини - SnimkiOt.com - безплатен DNS - Whois разузнаване - Poblizo.com : пътешествия