electronics, repairs, service manuals and datasheets discussion community for the repairs professionals and technicians
FAQSearchMembersGroupsRegisterProfilePM'sLogin/Out
iwatsu ss-6122 oscilloscope

 
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs
View previous topic :: View next topic  
Author Message
yashiro32



Joined: 05 Sep 2007
Posts: 3

PostPosted: Wed Sep 05, 2007 3:56 pm    Post subject: iwatsu ss-6122 oscilloscope Reply with quote

Hi,

I bought a Iwatsu ss-6122 oscilloscope for a year and recently when i turned it on, i could not find the trace. I tried to adjust the vertical position knob to the highest position and i could see the trace appearing at the bottom of the screen. After that, when i adjust the vertical position knob to lower down the position the trace seems to adjust down and cannot be seen anymore. Does anyone know which parts or components of the circuit the problem lies on?
Back to top
View user's profile Send private message
torbjorn



Joined: 07 Jun 2007
Posts: 370
Location: Sweden

PostPosted: Thu Sep 06, 2007 7:50 am    Post subject: Reply with quote

Without any specific knowledge of this specific oscilloscope, i could bet that the problem is in one half of the push-pull vertical deflection output amplifier. For exemple, a shorted output transistor, burnt-off collector resistor or something like that. Each half of this amplifier usually looks like the video output amplifiers of a tv or monitor.
Back to top
View user's profile Send private message
yashiro32



Joined: 05 Sep 2007
Posts: 3

PostPosted: Sun Sep 09, 2007 4:56 am    Post subject: iwatsu ss-6122 oscilloscope Reply with quote

Yes ,

one of the push pull transistor in the vertical deflection output amp Q34 - 2SC1412 (NPN tranistor) is damaged . As that part is obsolete, i replced it with a cross reference part - 2N5109 and the trace returned to the center of the screen .

But now, there is another problem. After i turned on the oscilloscope for around 15 -20 minutes there seems to be a double image drifting vertically up and down corresponding the trace and readings . Where could the problem be ? Could it have something to do with the Focus/Z-axis part of the circuit ?
Back to top
View user's profile Send private message
torbjorn



Joined: 07 Jun 2007
Posts: 370
Location: Sweden

PostPosted: Sun Sep 09, 2007 5:55 pm    Post subject: Reply with quote

Maybe, it could be a problem in the switching between the two vertical channels. Try switching off the other channel (or change between "alt" and "chop" mode) to see if the ghost image disappears.

Also, it is important to have good symmetry in the push-pull output stage. It is a good idea to change both transistors even if only one of them has failed, and make sure that the replacement transistors are fairly matched regarding hfe factor etc.
Back to top
View user's profile Send private message
yashiro32



Joined: 05 Sep 2007
Posts: 3

PostPosted: Mon Nov 26, 2007 1:03 am    Post subject: Reply with quote

Does anyone have the user and service manual and the schematic diagram of this IWATSU ss-6122 oscilloscope?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs All times are GMT
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Електроника София - Service Manuals Free Download - Prikachi - Service Diagrams

Free TV Schematics Download - HARDW.net - Pinout Master - Jabse Search - Jabse.InK  - Pulsator

Connector Pinout Forum - Новини - SnimkiOt.com - безплатен DNS - Whois разузнаване - Poblizo.com : пътешествия