electronics, repairs, service manuals and datasheets discussion community for the repairs professionals and technicians
FAQSearchMembersGroupsRegisterProfilePM'sLogin/Out
Picture problem on my Big screen TV

 
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs
View previous topic :: View next topic  
Author Message
jeffreyz75



Joined: 21 Mar 2008
Posts: 4

PostPosted: Fri Mar 21, 2008 3:22 pm    Post subject: Picture problem on my Big screen TV Reply with quote

Hi,
I have a Panasonic Big screen projection TV. Model # PT-53WX42F. Everything works fine but the picture. The picture has 2 or sometime 3 "ghost images". Kind of a layered effect. You can see purple and green. Like the pictured is doubled. Like the one picture has purple in it then the next picture is behind and drops down an inch and has green. Can anyone give me an idea of whats wrong or what I might have to pay?
Thanks!
Back to top
View user's profile Send private message
minnie



Joined: 18 Aug 2005
Posts: 2877
Location: Hell

PostPosted: Fri Mar 21, 2008 4:14 pm    Post subject: Reply with quote

You're convergence IC's have failed. They should be STK392-110's and the 1 ohm resistors need to be checked. If you have someone do it, $325/$350. You can do it your self for about $50.
Back to top
View user's profile Send private message Send e-mail
jeffreyz75



Joined: 21 Mar 2008
Posts: 4

PostPosted: Fri Mar 21, 2008 5:08 pm    Post subject: Reply with quote

Thanks minnie. I greatly appreciate your help. I will get the IC's and check the 1 ohm R's. I will let you know how it goes
Back to top
View user's profile Send private message
jeffreyz75



Joined: 21 Mar 2008
Posts: 4

PostPosted: Thu Mar 27, 2008 3:23 pm    Post subject: Reply with quote

Hi minnie,
I got the convergence IC's and I installed them. I neglected to check the 1 Ohm resistors. When I powered up the TV it shut off as soon as the picture came on and the power light blinks 3 times. I unplugged the TV then plugged it back in and powered it on again this time I looked in the back as I did it. I noticed one of the resistors glowed red before it shut off again. I changed the resistor and now the TV stays on but when I try to use the convergence feature the green pattern is way off and wont align. Did I fry the new IC's? Please help.

Thanks
Back to top
View user's profile Send private message
minnie



Joined: 18 Aug 2005
Posts: 2877
Location: Hell

PostPosted: Thu Mar 27, 2008 9:48 pm    Post subject: Reply with quote

Recheck the resistors. If there all ok, yes you fried the ic.
Back to top
View user's profile Send private message Send e-mail
jeffreyz75



Joined: 21 Mar 2008
Posts: 4

PostPosted: Mon Apr 07, 2008 11:05 pm    Post subject: Reply with quote

Hi,
I checked the resitors and they all seem ok. I put new convergence IC's in and it still is not letting me adjust the colors correctly. The red crosshairs wont go up, the green seems to work ok. The blue too. And now after 5 minutes the TV shuts off. I got the IC's from a site called Blue Star International Components. They were only around 7 dollars a piece. Do you think they are no good? Why is my TV shutting off? Can you help me?

Thanks!!

Jeff
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs All times are GMT
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Електроника София - Service Manuals Free Download - Prikachi - Service Diagrams

Free TV Schematics Download - HARDW.net - Pinout Master - Jabse Search - Jabse.InK  - Pulsator

Connector Pinout Forum - Новини - SnimkiOt.com - безплатен DNS - Whois разузнаване - Poblizo.com : пътешествия