electronics, repairs, service manuals and datasheets discussion community for the repairs professionals and technicians
FAQSearchMembersGroupsRegisterProfilePM'sLogin/Out
Hitachi 53fdx20b rear projection tv troubleshooting problem

 
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs
View previous topic :: View next topic  
Author Message
Boy447374



Joined: 14 Feb 2009
Posts: 2

PostPosted: Mon Apr 13, 2009 8:38 am    Post subject: Hitachi 53fdx20b rear projection tv troubleshooting problem Reply with quote

Hitachi 53fdx20b Rear Projection TV had a conversion problem. Symptoms were typical image ghosting. Replaced STK392-110 IC's. Checked resistors. They all checked out okay. Turned unit on and now red power light flashes off-on-off-on ect... Please Help Me. Resistors are fine.
Back to top
View user's profile Send private message
jts1957



Joined: 24 Nov 2008
Posts: 2472
Location: Far, Far Away

PostPosted: Mon Apr 13, 2009 4:56 pm    Post subject: Reply with quote

Recheck your soldering for unintentional bridges. Also splashes.
Back to top
View user's profile Send private message
minnie



Joined: 18 Aug 2005
Posts: 2877
Location: Hell

PostPosted: Mon Apr 13, 2009 7:43 pm    Post subject: Reply with quote

Where did you get the IC's? If it was working before you changed them more than likely bad IC's.
Back to top
View user's profile Send private message Send e-mail
Boy447374



Joined: 14 Feb 2009
Posts: 2

PostPosted: Tue Apr 14, 2009 3:34 pm    Post subject: Reply with quote

I checked for bridges on the IC's and I also put the original IC's back in. I even tried two new IC's. There is no change at all. There is something else that is no doubt wrong now. I uplugged the PDKP connector and the unit does not cycle on-off anymore with PDKP disconnected. It just shuts down immediately. I suspect a problem in the deflection board. Can someone walk me through some troubleshooting? I can tell you that I have went through some of the troubleshooting flowchart in the Service Manual and I checked the HOT. Everything I've checked seems okay.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs All times are GMT
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Електроника София - Service Manuals Free Download - Prikachi - Service Diagrams

Free TV Schematics Download - HARDW.net - Pinout Master - Jabse Search - Jabse.InK  - Pulsator

Connector Pinout Forum - Новини - SnimkiOt.com - безплатен DNS - Whois разузнаване - Poblizo.com : пътешествия