electronics, repairs, service manuals and datasheets discussion community for the repairs professionals and technicians
FAQSearchMembersGroupsRegisterProfilePM'sLogin/Out
[SOLVED] LCD samsung LE40A656 - no picture, no osd

 
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs
View previous topic :: View next topic  
Author Message
joao2004



Joined: 24 Jul 2008
Posts: 4

PostPosted: Sun Feb 19, 2012 4:18 pm    Post subject: [SOLVED] LCD samsung LE40A656 - no picture, no osd Reply with quote

Hi, i have an lcd tv samsung LE40A656 with the following fault:

tv turns on ok, but no picture, no OSD ! back-light is working and psu is ok

red led blinks 5 times at switch on

tv is about 3/4 year old but it only has a few hours of service.

any help?


Last edited by joao2004 on Wed Feb 22, 2012 4:29 pm; edited 2 times in total
Back to top
View user's profile Send private message
Guest






PostPosted: Tue Feb 21, 2012 12:20 am    Post subject: Reply with quote

I can't find a fault listed the same as you're describing. The only one similar refers to the screen going black after a while, and the advice is to resolder joints on PSU. Generally capacitors in the PSU seem to cause a variety of symptoms too.

Check all cables are making good contact too.

E-mail me at: "james q b 2001 at yahoo dot co dot uk" (remove spaces and replace words - dot, at - with corresponding symbols as required) if you want the service manual for this set. You'll be able to check voltages are correct, etc., then, as well as further fault finding.
Back to top
chappers



Joined: 21 Feb 2012
Posts: 3

PostPosted: Tue Feb 21, 2012 12:47 am    Post subject: Reply with quote

Can also be due to firmware flash gone wrong. Do you have on-screen display at all, like channel number, etc?

Sounds like the problem described here (LED flashing 5 times):

http://www.avforums.com/forums/lcd-led-lcd-tvs/1087844-samsung-series-6-bad-flash-req-rome-flash-downloader-v4-x.html

See if you can download the correct BIN file and re-flash the firmware using the software linked to at the above website. Good luck. Let us know if you get it fixed.
Back to top
View user's profile Send private message
joao2004



Joined: 24 Jul 2008
Posts: 4

PostPosted: Tue Feb 21, 2012 10:27 am    Post subject: Reply with quote

chappers wrote:
Can also be due to firmware flash gone wrong. Do you have on-screen display at all, like channel number, etc?

Sounds like the problem described here (LED flashing 5 times):

http://www.avforums.com/forums/lcd-led-lcd-tvs/1087844-samsung-series-6-bad-flash-req-rome-flash-downloader-v4-x.html

See if you can download the correct BIN file and re-flash the firmware using the software linked to at the above website. Good luck. Let us know if you get it fixed.


Thank's for the tip...i will try that

There's no OSD at all !!!
Back to top
View user's profile Send private message
joao2004



Joined: 24 Jul 2008
Posts: 4

PostPosted: Wed Feb 22, 2012 12:15 am    Post subject: Reply with quote

I was unable to get mtktool to communicate with the tv... but i tried to update firmware thru usb flash drive and i think it updated (after ~2min tv shut down) but still the same...

i checked that audio works fine...

checking voltages, there is something strange with the +33v (to tuner). At power up there is 33v, but after ~5 sec it goes down to ~13v. if i keep changing channel it varies between ~12v to ~23v.

Also B9v seems to have some ripple (~0.4Vpp)

I maybe try to replace the TCON board...
Back to top
View user's profile Send private message
joao2004



Joined: 24 Jul 2008
Posts: 4

PostPosted: Wed Feb 22, 2012 4:27 pm    Post subject: Reply with quote

Problem Solved... it was a fault at TCON board

later will post some details.
Back to top
View user's profile Send private message
dhoshi21



Joined: 15 May 2013
Posts: 1

PostPosted: Wed May 15, 2013 11:42 am    Post subject: Reply with quote

joao2004 I am waiting detail
_________________
Samsung LCD TV Price in Pakistan
Back to top
View user's profile Send private message
Guest






PostPosted: Wed May 15, 2013 11:59 am    Post subject: Reply with quote

dhoshi21 wrote:
joao2004 I am waiting detail


Sorry... i forgot about this post

it was a faulty diode (open or short, can't remember...) near a voltage converter chip (3.3v i think)
Back to top
Guest






PostPosted: Sun Apr 20, 2014 9:16 pm    Post subject: Reply with quote

ACK do you know which diode it was , have same problem
Back to top
Display posts from previous:   
Post new topic   Reply to topic    Electronic equipment repair and service manual search discussion Forum Index -> Equipment Repairs All times are GMT
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Електроника София - Service Manuals Free Download - Prikachi - Service Diagrams

Free TV Schematics Download - HARDW.net - Pinout Master - Jabse Search - Jabse.InK  - Pulsator

Connector Pinout Forum - Новини - SnimkiOt.com - безплатен DNS - Whois разузнаване - Poblizo.com : пътешествия